Issue:

  • Quickbooks Error Code (2500): Invalid Reference Id. Something you're trying to use has been deleted. Check the fields with accounts, customers, items, vendors or employees.

Environment:

  • Syngency

  • Quickbooks Online

Additional Information:

  • For a full list of Quickbook Error Codes that you might encounter, click here.

  • For more information on how you can find Quickbooks errors in your account, click here.

Cause:

A few possible causes of this error message could be:

  • The item referenced was deleted in QBO or Syngency.

  • The Contact may have originally been duplicated in Syngency. Then the incorrect Contact was deleted in QuickBooks Online, leaving no Contact for Syngency to sync future updates/items, which would produce this 2500 error.

  • If you are tracking firm users on bills, a Class or Subclass related to a User in Syngency may have been deleted.

Resolution:

Change the name of the remaining QBO Contact to something unique, clicking Retry on the QBO error for the Contact itself, and then in QBO merging the previously existing contact into the newly created one. For details on how to merge a Contact within QBO, please see here.

Change the name of the Contact in Syngency. This will create a new contact in QBO which you can then merge the old contact in QBO to. For details on how to merge a Contact within QBO, please see here.

If you are seeing a "Code (2500): Invalid Reference Id : Klasses element id not found" error, attempt the steps here. If that does not resolve the issue, contact Syngency Support stating this error message.

This is only one example of solving this issue, and other situations may exist. If further assistance is needed please contact Syngency Support using the chat bubble in the lower right hand corner of your screen.

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